South G7 RTK not working anymore (Rover)

Hi all,

we’ve had the G7 for a while now and its been working really good. A couple of weeks ago it wouldn’t get a GPS lock, I am not even talking about RTK but GPS in general. No satellites in view.

So after some trail and error I just factory rest the unit and the GPS reception started working again.

I re-added the RTK/Ntrip data and selected the mount point I was using before. After this the unit says logged on to server success.

But the GPS fix doesn’t go from single to fixed.

I am completely clueless on how to proceed, I have tried every mount point from our supplier but I cant get any RTK fix.

I hope someone can point me in the right direction to fix this issue.

Many thanks in advance!

Kind regards,

Hi, Niels, please feedback the SN of your receiver? thanks

Hi @south-michelle

apparantly i dont get any notifications if there are replies here.

Thanks for investgating, the serial is S910B8148510261.

Can you see the current firmware version on it? is the registration code permanent on it? which controller software you are using?

The registration on it expired once but then I got the permanent license trough a topic on here.

For controller software we don’t use anything fancy, just connect Qgis to it over ip or use an android app trough bluetooth.

I tried to check wether there are any updates and according to the device there is an update but it does not succeed in downloading it, can I download it somewhere and do an offline update? I attached a screenshot of the update window.

Screenshot 2023-03-16 at 10.48.03

The system information is the following:

Model: G7mini
Serial Number: S910B8148510261
Hardware ID: 0NN0E0100000006003133D
Software ID: 2000000000000000
Ethernet MAC: 00:81:48:51:02:61
Ethernet IP:
WiFi IP:
Bluetooth MAC: 00:00:00:00:00:00
Hardware Version: R91000001
Firmware Version: 1.09.210825.R910GL
OEM Version: 601AA-21804-1
Web Version: 1.09.210820.RG60WEB
Expire: 20500101

Many thanks in advance @south-michelle

please don’t use the online update, it is not stable. you can try to load the firmware manually, please let us know your email address, thanks.

Hi @south-michelle , you can use