Can't connect to web UI

Hi, i cant connect to our new south galaxy g2.

I am trying to connect over wifi, but the south_xxxx. only appears occasionally. And when it does i am not able to connect to it.
I am also unable to connect via. usb. Here the folders are empty, and i cant update usb driver, on my company computer (data security).
The manual that i have also doesn’t seem to correspond to the product we have, i am unable to get the usb mode prompt. And my display doesn’t show what the manual does.

I have restored factory settings, restarted my computer, turned off/on wifi. none has changed


Please send me the SN of this G2 firstly.
And do you ever try another computer or smart phone to connect it? The problem still exist by these ways?
For the USB issue, please also try with the other PC.

And you can download the manual of G2 here.

Best Regards,

Sn is SG50C2148622272PKA.
I tried connecting over wifi with my phone (same result).
Yes, it is the same manual i have, i dont get to “start to set USB mode”, the “battery” indikator shows a circle with a vertical line??

Okay, i got acces over usb now. Where can i find latest firmware, and what else can i do to get wifi connection?


Now the G2 is the Integrated Storage and WebUI. So it don’t need to change the USB mode.

You can download the latest Firmware here.

Best Regards,

So i can just not acces over wifi?
Can i get a new Code, mine is seemingly expired?

New code: